·afterdawn.com home  ·Search  

This discussion forum has been closed.
Starting new topics or replying to existing topics is no longer possible.
We welcome all users to use AfterDawn's discussion forums instead.
 

 

DVD X Rescue and Platinum

Get AnyDVD HD and copy any DVD or Blu-ray disc with ease!
Posted Message
lerwick 
Newbie

10 Jan 2004 3:55 AM
hi,
I bought platinum which came with x rescue and then tried using X Rescue for the first time today after getting some errors copying a DVD. The Rescue button would not light up so I grabbed the latest upgrade of x rescue from the ftp site. Now when I start X rescue it wants a license number. My Platinum license id does not work. So after applying the lastest patch I now have an unusable (it was actually already uunusable) copy of X Rescue. How can I fix this situation????
thanks, Lerwick (Platinum works ok though).

Dell Inspiron 8600 XP 500MB RAM with DVD Burner.
tvfilmfl 
Inactive

11 Jan 2004 2:18 PM
I also am having a problem with the DVDxRESCUE that came with my Platinum. It doesn't work, so I felt getting the upgrade on the 321Studio support site might solve the problem. It won't allow me to download the newest version of RESCUE. I have only my PLatinum ID & PASSWORD both of which it won't recognize. I have written to a Tier 3 support person who gave me some help with getting Platinum & Xpress running on my two machines, but has ignored the three e-mails I've sent about this. If I have RESCUE legally - which I do since it was on the PLatinum disc, I should be able to get the updates. HELP!
lerwick 
Newbie

11 Jan 2004 4:50 PM
I also could not originally download the update using my normal signon and password as only platinum updates were available but the first thread on the x rescue forum refers to an ftp site ftp://products.321studios.com/6184/ which has the x rescue update. After loading that I was prompted for a license id and password. I use the system restore to revert back to the prior version which all worked; then reloaded the updated in a different directory and then rescue button would work using the original copy of x rescue after that but the entire process still flopped when it came to burning the dvd. It was a dodgy attempt at getting it to work anyway. A licensed copy of the update would be good but my suspicion is that the update is not free as it was a giveaway with platinum and the original copy does not work! Not a great freebie that one..maybe others did get it to work though.
Poconobob 
Newbie

13 Jan 2004 2:16 PM
double post, sorry

This message has been edited since posting. Last time this message was edited on 13 Jan 2004 2:17 PM

Poconobob 
Newbie

13 Jan 2004 2:17 PM
Same problem here...tech support said they had no reports of any bug reports being submitted other than mine so there is no problem. I said apparently there is a problem because I have one and besides you wouldn't have a bug report had it not been "bug" proof. I was then told I must get permission to obtain the update from someone else higher up. WAIT, stop, I said that goes directly against your ad and directly violates everything you use in your bag of tricks to get people to sign up. If you'll listen instead of giving me rhetoric about mine being the only problem I'll tell you the issue.

I went on...I explained the problem, it is simply they've bundled a new version of Platinum with an old version of Rescue...so the conflict lies in the build number of rescue.. It isn't as simple as just downloading the updated version as the Patin Coffin is a different version as well. Guys, it was reasons like this tech that I stopped buying OFF THE SHELF computers and learned the trade myself. I knew more than he did; that is NOT good, he wanted me to do a MSCONFIG and I said wait a minute, first WHY...well, we don't want all the drivers to load or all your start items to start. I said with XP you can start and install with Safe Mode and be actually better off and then not possibly cause a driver conflict when YOUR software causes a conflict with an already resident driver like MY NETWORK. "oh".... So after 20 minutes, I got another license key for DVD Rescue and downloaded it. Now remember, that Patin Coffin is different...the best way around that is to simply take their install, do the install of Platinum, hit cancel on Rescue...then delete the install file for rescue and copy/paste in the 2.1.1 file which then does not install the older Patin Coffin version, otherwise in Hardware, you'll have two.

The simple way for them to fix this for all would be to give us a simple separate download...and by the way, nothing was FREE, I reason someone thinks it was free because it was included at no charge. That is a misnomer as they simply included it....you paid for it, otherwise by definition FREE WOULD IN ESSENCE mean it was FREE even if you cancel Platinum or FREE for all to download or FREE without a product key. Free is no strings...like I got that rebate..that is as free as the software...if I cancel, I don't get either..but it meaning DVD X Rescue will have the identical support as THEY included it, they put in a wrong copy.

Ya, I'm kinda ticked because if you've experienced the same issues I have then listened to the recording OVER AND OVER then get someone who knows LESS about computers than you do, uses paths to get to areas of the computer like I did with Win95. I know, I know...not everyone is an expert, I am FAR from it but I choose to learn my mistakes and once I know how to properly install the suckers it won't happen again.

I am STILL...since Dec 22nd not getting a reply why I cannot have Platinum separate from Rescue...I have Rescue separate from Platinum....and I paid for Platinum which has embedded software that is OLD outdated Rescue....

You should have version 2.1.1 NOT 2.1.0

I hope it helps someone, mostly I'm here to bring everyone up to what I've experienced so we can try to get answers. Perhaps this idea might work, if we all used the same senior technician, CERTAINLY not mine...who was level 1....then we could make progress.

Again to sum it up, we have a problem that most don't because they don't bundle both together except for that small period around the holidays, therefore few bug reports come in.....IT IS ALL LOGICAL.

Geezz

Bob
Get AnyDVD HD and copy any DVD or Blu-ray disc with ease!
It is already over 90 days since last post to this thread, you're not allowed to post here anymore.