·afterdawn.com home  ·Search  

This discussion forum has been closed.
Starting new topics or replying to existing topics is no longer possible.
We welcome all users to use AfterDawn's discussion forums instead.


Platinum 3.1X Simple and Advanced Doesn't See My DVD Drive

Get AnyDVD HD and copy any DVD or Blu-ray disc with ease!
Posted Message

8 Oct 2003 9:26 AM
I installed the latest available version of Platinum off of the website as an authorized download last night. Didn't have a problem with installation, and, in fact, copied and burned a DVD. After rebooting my system and trying to run the program again this morning, as soon as I click Start to begin the copy process, an error window pops up and terminates the program.

I had initially selected "No" to allow DriveSelect to run at system Startup (thinking that I could manually run this executable just prior to running the program). Wrong. I did run the DriveSelect executable, but in running Simple, under preferences, my DVD drive is not visible. I then changed my options so that DriveSelect would run at system Startup. Still no dice, and the program still faults out when I press Start to copy a DVD in Simple or Advanced.

In addition to the above, could someone tell me if Platinum has a need to make any sort of network connection to run the program? I ask this because prior to running I disable all Internet connections from my firewall. I also noticed after copying and burning a DVD last night, that even though I removed Platinum in my firewall as a program authorized to connect to the Internet (after registering, that is), after burning the DVD I saw where Platinum reappeared as a program listing again in my firewall. Is Platinum using the same tricks as DVD X Copy Express (that program will make five network connection attempts at program execution), but in a more subtle or stealthy way? Guess I need to run my packet sniffer and find out next time. ;)

Anyway, does anyone have any ideas why my DVD drive isn't listed within Platinum? I'm guessing that's why I'm getting these errors when pressing Start (to begin copying). Oh, and by the way, just out of curiosity I ran the Rescue program, and it DOES see my DVD drive. Why then, are Platinum Simple and Advanced not?

Senior Member

8 Oct 2003 12:47 PM
DRIVE SELECT only works for choosing your burner if you have more than one burner on your system. In the 321 folder where PLATINUM is installed is an executable named PCSETUP.exe. Double click on that and see if your hardware is listed.
Get AnyDVD HD and copy any DVD or Blu-ray disc with ease!
It is already over 90 days since last post to this thread, you're not allowed to post here anymore.